Skip to main content.

Installers

These are the official installation packages for RPGXplorer. These should not be used to update your existing copy to a new version.

RPGXplorer 1.9.0
Download

RPGXplorer version 1.9.0 installer.


RPGXplorer 1.9.5
Download

RPGXplorer version 1.9.5 installer.


RPGXplorer 1.9.5.1
Download

RPGXplorer version 1.9.5.1 installer.

Patches

These are the official patches for RPGXplorer. All of the patches are incremental, so if you are moving from version 1.9.0 to 1.9.5.1, you must first apply the patches for 1.9.5, then apply the patch for 1.9.5.1.

1.9.0 -> 1.9.5

This is a 3-step patch. Download all 3 files. Extract the Files.zip archive and place the contents in your RPGXplorer directory, overwriting any previous files. Next, run the patch to update the application. Finally, extract the Data.zip file and start RPGXplorer. With RPGXplorer open, import the XML file(s) that you extracted from the Data.zip file.


1.9.5 -> 1.9.5.1

This is a 3-step patch. Download all 3 files. Extract the Files.zip archive and place the contents in your RPGXplorer directory, overwriting any previous files. Next, run the patch to update the application. Finally, extract the Data.zip file and start RPGXplorer. With RPGXplorer open, import the XML file(s) that you extracted from the Data.zip file.


1.9.5.1 -> 2.0.0 Alpha d

This is an alpha version of 2.0.0 which fixes some previous issues, adds new features, and improves the overall performance of RPGXplorer. While it is still an alpha version, it is stable and is certainly worth using, especially if you have been having performance issues due to a large database. This is a single file that replaces your existing copy of RPGXplorer.exe.